Luminance HDR

Luminance HDR es una aplicación de código abierto cuyo objetivo es proveer un soporte de proceso a imágenes HDR.

Características principales de Luminance HDR:

  • Crear archivos HDR de un grupo de imágenes (JPEG, TIFF 8bit and 16bit, RAW) tomadas de la misma escena con diferentes exposiciones.
  • Guardar y abrir imágenes HDR.
  • Rotar, agrandar/achicar, cortar imágenes HDR.
  • Tonalizar imágenes HDR.
  • Copiar información exif entre grupos de imágenes.
  • Soporte de internacionalización.

Formatos HDR soportados:

  • OpenEXR (extensión: exr);
  • Radiance RGBE (extensión: hdr);
  • Tiff: 16bit, 32bit (flotante) and LogLuv (extensión: tiff);
  • Raw formato de imagen.
  • PFS formato nativo.

Formados LDR soportados

  • JPEG;
  • PNG;
  • PPM;
  • PBM;
  • TIFF (8 bit).

Procedimiento:

Se debe agregar el repositorio (Ubuntu no tiene a luminance-hdr como paquete).

< sudo add-apt-repository ppa:philip5/extra
> You are about to add the following PPA to your system:
> Ubuntu experimental rolling release repository.
> Mainly assorted media apps and other programs that I use myself or by requests. 
> More info: https://launchpad.net/~philip5/+archive/extra
> Press [ENTER] to continue or ctrl-c to cancel adding it
> gpg: keyring `/tmp/tmpgh2rbU/secring.gpg' created
> gpg: keyring `/tmp/tmpgh2rbU/pubring.gpg' created
> gpg: requesting key 43C56F3F from hkp server keyserver.ubuntu.com
> gpg: /tmp/tmpgh2rbU/trustdb.gpg: trustdb created
> gpg: key 43C56F3F: public key "Launchpad extra" imported
> gpg: Total number processed: 1
> gpg: imported: 1 (RSA: 1)
> OK

Se debe actualizar la información de los repositorios de software para que vea disponibles los nuevos paquetes.

< sudo apt-get update
> Get:1 http://us.archive.ubuntu.com precise-updates Release.gpg [198 B] 
> Get:2 http://security.ubuntu.com precise-security Release.gpg [198 B]
> ...

Finalizado este paso se procede a la instalación del paquete y sus dependencias.

< sudo apt-get install luminance-hdr
> Reading package lists... Done
> Building dependency tree 
> Reading state information... Done
> The following packages were automatically installed and are no longer required:
> linux-headers-3.2.0-30 libbabl-0.0-0 libgegl-0.0-0 linux-headers-3.2.0-30-generic
> Use 'apt-get autoremove' to remove them.
> The following extra packages will be installed:
 freeglut3 hugin-data hugin-tools libboost-regex1.46.1 libboost-signals1.46.1 libboost-system1.46.1 libboost-thread1.46.1 libglew1.5 libgsl0ldbl libpano13-2 libpano13-bin
 libzthread-2.3-2
> Suggested packages:
> autopano-sift-c autopano-sift glew-utils1.5 gsl-ref-psdoc gsl-doc-pdf gsl-doc-info gsl-ref-html
> The following NEW packages will be installed:
> freeglut3 hugin-data hugin-tools libboost-regex1.46.1 libboost-signals1.46.1 libboost-system1.46.1 libboost-thread1.46.1 libglew1.5 libgsl0ldbl libpano13-2 libpano13-bin
 libzthread-2.3-2 luminance-hdr
> 0 upgraded, 13 newly installed, 0 to remove and 23 not upgraded.
> Need to get 21.6 MB of archives.
> After this operation, 54.3 MB of additional disk space will be used.
> Do you want to continue [Y/n]? < y
> WARNING: The following packages cannot be authenticated!
> freeglut3 hugin-data libboost-regex1.46.1 libboost-signals1.46.1 libboost-system1.46.1 libboost-thread1.46.1 libglew1.5 libpano13-2 libzthread-2.3-2 hugin-tools libgsl0ldbl libpano13-bin luminance-hdr
> Install these packages without verification [y/N]? < y ... 

Deja un comentario